Page Author Not Working

Home Forums Iconic One Pro Support Page Author Not Working

This topic contains 6 replies, has 3 voices, and was last updated by  SElsenrath 4 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #941

    SElsenrath
    Participant

    I have allowed the author link to be shown but when I review the pages that are on the website, it does not show the author link. When I manually go to the author link, it does not display any of the information from the profile I created.

    #943

    Themonic-Support
    Keymaster

    This is because you are using a static page on homepage and there are no posts on your websites only pages. The theme by default doesn’t show Author on Pages. Author is only displayed on posts.

    All themes are built this way because for eg. if you choose to enable author for single pages then all pages on your site will have author, even the about page, terms and conditions page which is not a good idea.

    If you still want to display author on single pages, then do the following:

    Open content-page.php,
    Now paste the following code after line 21 ()

    	<div class="clear"></div>
    	<div class="author-info">
    		<div class="author-avatar">
    			<?php echo get_avatar( get_the_author_meta( 'user_email' ), apply_filters( 'themonic_author_bio_avatar_size', 68 ) ); ?>
    		</div><!-- .author-avatar -->
    		<div class="author-description">
    		<?php printf( __( 'Author: %s', 'themonic' ), get_the_author() ); ?> 
    	</div><!-- .author-info -->
    
    #947

    SElsenrath
    Participant

    Alright, I see what you are talking about there. Tried it and that created the Author snippet for me. The main problem I am talking about is that the author page and information itself has no content. The user information is filled out, biography website info social network pages and such but none of that appears on the author page. Nor is it showing up in the snippet that I just put into the page.

    I’m not a code person and so I appreciate the time you are taking to assist on customizing this for me. May be a good addition to a future update a check box that asks if the user would like this option.

    #950

    Sydney
    Member

    The author page is not working on my theme either. I do not have it set for static front page. I have tried everything and it simply does NOT work! So following your advice here….Thanks!

    #952

    Themonic-Support
    Keymaster

    Could you please check by creating a new author.

    After doing this the Author area should start to display. Also, you might want to doublecheck that the author profile pages are showing bio information at the admin side.

    It works like this:

    Author area kicks in when there is more than one author. For eg. one admin and one editor with filled in bio.

    If everything is setup correctly, you should have author page at

    http://plexusambassador.com/author/authorname/

    ——–
    If the above do not work, send in your login details via the contact page, I would be happy to look at it.

    #953

    Themonic-Support
    Keymaster

    @Sydney

    Kindly create a separate thread, your case is different as you are moving and importing from blogger to wordpress.

    #957

    SElsenrath
    Participant

    I just installed the theme on a separate website of mine and the author info is working just fine without me doing anything… I’m not sure why it won’t work on plexusambassador website. It has to be something on my end that is crossed.

    I already had this wordpress site built when applying the theme. I went from the free theme to the paid theme. The other site I just uploaded w/o any content and put the theme on it fresh to test the author page specifically. I am just going to copy the little content I have on the site and go at it from scratch, since I now see it’s not a glitch in your theme but a glitch in me.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.