PHP 7 compatibility

Home Forums Iconic One Pro Support PHP 7 compatibility

This topic contains 1 reply, has 2 voices, and was last updated by  Themonic-Support 2 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4819

    Sprekendmartijn
    Participant

    According to the PHP7 compatibility check Iconic Pro (the most recent version) is not able to run on PHP7. (3 warnings, 1 error). Are you aware of this?

    
    FILE: /home/[CUSTOMER]/domains/[DOMAIN]/public_html/site/wp-content/themes/iconic-one-pro/inc/widget-recent-thumbnail.php
    --------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    --------------------------------------------------------------------------------------------------------------------------
     10 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    --------------------------------------------------------------------------------------------------------------------------
    
    FILE: /home/[CUSTOMER]/domains/[DOMAIN]/public_html/site/wp-content/themes/iconic-one-pro/inc/widget-feed-subscribe.php
    ------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------------------------
     20 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ------------------------------------------------------------------------------------------------------------------------
    
    FILE: /home/[CUSTOMER]/domains/[DOMAIN]/public_html/site/wp-content/themes/iconic-one-pro/inc/widget-popular-posts.php
    -----------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------------------
     14 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    -----------------------------------------------------------------------------------------------------------------------
    
    FILE: /home/[CUSTOMER]/domains/[DOMAIN]/public_html/site/wp-content/themes/iconic-one-pro/themonic/options/validation/preg_replace/validation_preg_replace.php
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
     26 | ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    
    #4820

    Themonic-Support
    Keymaster

    Thank you for the feedback, We will look into it and address the warnings in the next version update.

    The ERROR preg_replace() is a false positive in PHP7

    https://wordpress.org/support/topic/wrong-error-preg_replace-e-modifier-is-forbidden-since-php-7-0/

    https://github.com/wimg/PHPCompatibility/pull/300

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.